3DMark 11 requires Futuremark SystemInfo and .NET Framework 4.0. Also verify that the system service installed by Futuremark SystemInfo is not disabled in Windows services. 3DMark 11 versions prior to 1.0.4 also require the Microsoft Visual C++ 2010 runtime.

If you are running Windows Vista, you might be missing a Windows update that is required for DirectX 11 applications.